同花順長期橫盤突破指標公式

同花順公式 2019-06-27 06:00:55 突破 橫盤
DIFF := EMA(EMA(CLOSE,12) - EMA(CLOSE,26),5);
DEA := EMA(DIFF,9);
A1:DIFF;
A2:DEA;
macdOK:=CROSS(DIFF,DEA) ;
MACD賣點:=CROSS(DEA,DIFF) ;
中間值:=(HHV(H,60)+LLV(L,60) )/2;
ZHANGFU:=(H-REF(C,1))/REF(C,1)*100;
MA3:=MA(C,3);
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA25:=MA(C,25);
MA60:=MA(C,60);
MA90:=MA(C,90);
MA120:=MA(C,120);
A3:= (MA25-MA60)/MA60*100;
A4:= (MA25-MA90)/MA90*100;
A5:= (MA25-MA120)/MA120*100;
A6:=IF(C=O,C,O);
A7:=(H-A6)/A6*100;
A8:=(H-REF(C,10))/REF(C,10)*100;
A9:=(H-REF(C,11))/REF(C,11)*100;
A10:=(H-REF(C,12))/REF(C,12)*100;
A11:=(H-REF(C,13))/REF(C,13)*100;
A12:=(H-REF(C,14))/REF(C,14)*100;
A13:=(H-REF(C,15))/REF(C,15)*100;
A14:=(H-REF(C,16))/REF(C,16)*100;
A15:=(H-REF(C,17))/REF(C,17)*100;
A16:=(H-REF(C,18))/REF(C,18)*100;
A17:=(H-REF(C,19))/REF(C,19)*100;
A18:=(H-REF(C,20))/REF(C,20)*100;
A19:=(H-REF(C,21))/REF(C,21)*100;
A20:=100;
A21:=A8A20 AND
A9A20 AND
A10A20 AND
A11A20 AND
A12A20 AND
A13A20 AND
A14A20 AND
A15A20 AND
A16A20 AND
A17A20 AND
A18A20 AND
A19A20
;
B1:=30;
B2:=(L-REF(H,6))/REF(H,6)*100;
B3:=(L-REF(H,7))/REF(H,7)*100;
B4:=(L-REF(H,8))/REF(H,8)*100;
B5:=(L-REF(H,9))/REF(H,9)*100;
B6:=(L-REF(H,10))/REF(H,10)*100;
B7:=(L-REF(H,11))/REF(H,11)*100;
B8:=(L-REF(H,12))/REF(H,12)*100;
B9:=(L-REF(H,13))/REF(H,13)*100;
B10:=(L-REF(H,14))/REF(H,14)*100;
B11:=(L-REF(H,15))/REF(H,15)*100;
B12:=(L-REF(H,16))/REF(H,16)*100;
B13:=(L-REF(H,17))/REF(H,17)*100;
B14:=(L-REF(H,18))/REF(H,18)*100;
B15:=(L-REF(H,19))/REF(H,19)*100;
B16:=(L-REF(H,20))/REF(H,20)*100;
B17:=(L-REF(H,21))/REF(H,21)*100;
B18:=
B2B1 AND
B3B1 AND
B4B1 AND
B5B1 AND
B6B1 AND
B7B1 AND
B8B1 AND
B9B1 AND
B10B1 AND
B11B1 AND
B12B1 AND
B13B1 AND
B14B1 AND
B15B1 AND
B16B1 AND
B17B1
;
MID5 := MA(CLOSE,5);
UB5:=MID5+2*STD(CLOSE,5),colorred;
MID10 := MA(CLOSE,10);
UB10:=MID10+2*STD(CLOSE,10),colorred;
C1:=(H-REF(C,1))/REF(C,1)*100;
C4:=COUNT(C14.5,80 )=5 AND COUNT(C13,60 )=10;
D1:=MACDOK AND COUNT(MA60REF(MA60,1),60)=20 AND A310 AND C4 AND COUNT(A21,60)=60 AND COUNT(B18,20)=20 AND ZHANGFU3.5 AND LMA25 AND H MA25;
D2:= COUNT(MA90REF(MA90,1),90)=30 AND A410 AND C4 AND COUNT(A21,90)=90 AND COUNT(B18,20)=20 AND ZHANGFU3.5 AND LMA25 AND H MA25;
D3:= COUNT(MA120REF(MA120,1),120)=30 AND A510 AND C4 AND COUNT(A21,120)=120 AND COUNT(B18,20)=20 AND ZHANGFU3.5 AND LMA25 AND H MA25;
橫盤突破 := D1 OR D2 OR D3 AND CO;
買入:=橫盤突破 ;
FF:= (H - REF(C,BARSLAST(買入)) ) / REF(C,BARSLAST(買入) ) *100;
E3:= FF 15 AND BARSLAST(買入)30 AND CROSS(DEA,DIFF);
E2:= FF 15 AND BARSLAST(買入)30 AND UB5 REF(UB5,1) AND REF(UB5,1) =REF(UB5,2) AND REF(UB5,2) =REF(UB5,3) AND UB10 =REF(UB10,1) AND REF(UB10,1) =REF(UB10,2);
減倉:=E3 OR E2;
賣出:= FF-20 AND BARSLAST(買入)30 AND CROSS(DEA,DIFF);
止損:= FF-10 AND BARSLAST(買入) 20 AND COUNT(買入,21)=1;
離場:= FF-10 AND FF 15 AND BARSLAST(買入)==20 AND COUNT(買入,20)==1;
DRAWTEXT(買入 AND COUNT(買入,30)==1,DIFF+0.3,'建倉'),colorred;
DRAWICON( 買入 AND COUNT(買入,30)==1 ,DIFF,1);
DRAWTEXT( 減倉 ,DIFF-0.3,'減倉'),colorgreen;
DRAWICON( 減倉 ,DIFF,2);
DRAWTEXT( 賣出 ,DIFF+0.3,'賣出'),colorgreen;
GG:=COUNT(買入,30)0 AND CROSS(DEA,DIFF);
版權聲明

本文僅代表作者觀點,不代表MY指標公式網立場。
本文系作者授權MY指標公式網發表,未經許可,不得轉載。

文章內容來自互聯網,本網站無任何收費項目也不推薦股票
廣告投放請自行識別風險。本站無任何QQ群微信群

分享:

掃一掃在手機閱讀、分享本文

p3试机号开奖助手