大智慧電子股評主圖指標公式

大智慧公式 2019-06-14 06:00:38 主圖 股評
VA1:=IF((CLOSE 800),((AMOUNT / vol) / 100),((((CLOSE * 2) + HIGH) + LOW) / 4));
VA2:=((HHV(HIGH,15)) + (LLV(LOW,30))) / 2;
VA3:=EMA((MA(VA1,5)),10);
VA4:=EMA((MA(VA1,15)),10);
VA5:=EMA((MA(VA1,13)),21);
VA6:=((VA3 + VA4) + VA5) / 3;
波段線:EMA((MA(CLOSE,5)),5),COLORFB333F,LINETHICK2;
PARTLINE(波段線,波段線 (REF(波段線,3)),RGB(255,255,0)),LINETHICK2;
趨勢線:((((REF(VA6,1)) + VA6) + (REF(VA6,2))) / 3);
PARTLINE(趨勢線,CLOSE VA2,RGB(225,0,0),CLOSE = VA2,RGB(66,188,255)),COLORFFFF00,LINETHICK3;
天線:MA(REF(HHV(CLOSE,30),1),2),LINETHICK2,COLOR80E9FF;
地線:MA(REF(LLV(CLOSE,30),1),2),LINETHICK2,COLOR669900;
SD:=HHV(HIGH,13)=HIGH AND HIGHREF(HIGH,1);
SD1:=FILTER(SD,12);
SF:=LLV(LOW,13)=LOW AND LOWREF(LOW,1);
SF1:=FILTER(SF,12);
TSS1:=BARSLAST(SD1);
箱頂:REF(HIGH,TSS1),LINETHICK0,COLORRED;
TSS2:=BARSLAST(SF1);
箱底:REF(LOW,TSS2),LINETHICK0,COLORGREEN;
STICKLINE(OPEN=CLOSE,HIGH,LOW,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,7,0 ),COLOR005500;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR006600;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR007700;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR009900;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00BB00;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00DD00;
STICKLINE(OPEN=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00;
STICKLINE(CLOSEOPEN,HIGH,LOW,0.5,0 ),COLOR0000FF;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,7,0) ,COLOR000055;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,6,0) ,COLOR000066;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,5,0) ,COLOR000077;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,4,0) ,COLOR000099;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,3,0) ,COLOR0000BB;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,2,0) ,COLOR0000DD;
STICKLINE(CLOSEOPEN,CLOSE,OPEN,1,0) ,COLOR0000FF;
AA1:=MA(CLOSE,20);
AA2:=(CLOSE MA(CLOSE,5));
AA3:=(MA(CLOSE,5) MA(CLOSE,10));
AA4:=(CLOSE MA(CLOSE,10));
AA5:=(MA(CLOSE,5) MA(CLOSE,20));
AA6:=(CLOSE MA(CLOSE,20));
AA7:=REF(AA1,1);
AA8:=(AA1 AA7);
AAX:=(((((IF(AA2,10,(0 - 10)) + IF(AA3,10,(0 - 10))) + IF(AA4,10,(0 - 10))) + IF(AA5,10,(0 - 10))) + IF(AA6,10,(0 - 10))) + IF(AA8,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);
T := BARSLAST(DISPSTATUS=1)+1;
IF BARSTATUS=2 AND C200 AND ((CROSS(AAX,1) AND (V1 = V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTREL(500,20,'的量能理想,有明顯走強跡象,可以考慮中線進場參與,倉位在2/3左右。'),COLORRED,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((CROSS(AAX,1) AND (V1 V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTREL(500,20,'雖然走勢趨強,但量能還顯不足,可以考慮短線進場,倉位在1/2左右。'),COLORYELLOW,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((CROSS(AAX,1) AND (V1 V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTREL(500,20,'量價配合良好,但相對其它股票并沒有明顯走強,可以考慮短線進場,倉位1/2左右。'),COLORYELLOW,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((CROSS(AAX,1) AND (V1 = V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTREL(500,20,'形態尚可,但量能不足,股票也未完全走強,可以短線參與,倉位1/3左右。'),COLORYELLOW,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((CROSS(1,AAX) AND (V1 = V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTREL(500,20,'形態變壞,但走勢相對其它股票尚可,重倉者減持大半,清倉者可以觀望。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((CROSS(1,AAX) AND (V1 V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTREL(500,20,'隨大盤一起下跌,呈明顯縮量走勢,考慮到大盤風險,減持或清倉。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((CROSS(1,AAX) AND (V1 = V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTREL(500,20,'放量下跌,走勢明顯偏弱,離場觀望。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((CROSS(1,AAX) AND (V1 V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTREL(500,20,'縮量下跌,走勢偏弱,離場觀望。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((((AAX = 1) AND (REF(AAX,1) 0)) AND (V1 = V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTREL(500,20,'形態良好,強勢明顯,量能充足,可以繼續持有。'),COLORRED,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((((AAX = 1) AND (REF(AAX,1) 0)) AND (V1 V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTREL(500,20,'上行趨勢不變,強勢依然,但量能開始轉弱,注意風險。'),COLORRED,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((((AAX = 1) AND (REF(AAX,1) 0)) AND (V1 = V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTREL(500,20,'仍然具備上漲潛力,但股性偏弱,可考慮減倉。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((((AAX = 1) AND (REF(AAX,1) 0)) AND (V1 V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTREL(500,20,'走勢趨弱,量能不足,減持大部分籌碼。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((((AAX 1) AND (REF(AAX,1) 0)) AND (V1 = V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTREL(500,20,'形態不佳,注意成交量的變化,但目前不適合參與。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((((AAX 1) AND (REF(AAX,1) 0)) AND (V1 V2)) AND (DSLX = DSLX1)) THEN
DRAWTEXTREL(500,20,'趨勢不明,股價偏弱,注意量能變化,目前不宜參與。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((((AAX 1) AND (REF(AAX,1) 0)) AND (V1 = V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTREL(500,20,'有走強跡象,但量能不足,趨勢不明,不適合操作。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND ((((AAX 1) AND (REF(AAX,1) 0)) AND (V1 V2)) AND (DSLX DSLX1)) THEN
DRAWTEXTREL(500,20,'走勢太弱,沒有參與價值。'),COLORGREEN,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (CROSS(AAX,1) AND (V1 = V2)) THEN
DRAWTEXTREL(500,20,'大盤量能理想,有明顯走強跡象,可以考慮中線進場參與,倉位在2/3左右,'),COLOR8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (CROSS(AAX,1) AND (V1 = V2)) THEN
DRAWTEXTREL(500,20,'如前期經過一輪下跌,此時為最佳買點,但如果前期有過一段漲幅則介入需謹慎。'),COLOR8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (CROSS(AAX,1) AND (V1 V2)) THEN
DRAWTEXTREL(500,20,'大盤雖然走勢趨強,但量能還顯不足,如果前期經過一輪下跌,'),COLOR8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (CROSS(AAX,1) AND (V1 V2)) THEN
DRAWTEXTREL(500,20,'可以考慮短線進場,倉位在1/2左右,一旦量能放大可以加倉買入。'),COLOR8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (CROSS(1,AAX) AND (V1 = V2)) THEN
DRAWTEXTREL(500,20,'大盤形態走壞,重倉者可以減去大部分倉位。'),COLOR8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (CROSS(1,AAX) AND (V1 V2)) THEN
DRAWTEXTREL(500,20,'大盤縮量調整,注意風險,短線清倉觀望。'),COLOR8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (((AAX = 1) AND (REF(AAX,1) 0)) AND (V1 = V2)) THEN
DRAWTEXTREL(500,20,'大盤走勢良好,量能理想,可以繼續持有強勢股。'),COLOR8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (((AAX = 1) AND (REF(AAX,1) 0)) AND (V1 V2)) THEN
DRAWTEXTREL(500,20,'大盤形態良好,但量能稍顯不足,隨時準備減倉。'),COLOR8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (((AAX 1) AND (REF(AAX,1) 0)) AND (V1 = V2)) THEN
DRAWTEXTREL(500,20,'大盤趨勢不明,注意成交量變化,目前不適宜進場。'),COLOR8000FF,LINETHICK2,ALIGN1;
IF BARSTATUS=2 AND C200 AND (((AAX 1) AND (REF(AAX,1) 0)) AND (V1 V2)) THEN
DRAWTEXTREL(500,20,'大盤趨勢向下,量能萎縮,不適合進場。'),COLOR8000FF,LINETHICK2,ALIGN1;
MA20:=MA(C,20);
MA40:=MA(C,40);
MA60:=MA(C,60);
bias:=(C-MA20)/MA20*100;
SHOPEN:=OPEN;
SHHIGH:=HIGH;
SHLOW:=LOW;
SHCLOSE:=CLOSE;
SHAMOUNT:=AMOUNT;
SHVOL:=VOL;
J12:=(HIGH - ((HIGH - LOW) / 3));
J23:=(LOW + ((HIGH - LOW) / 3));
T1:=(((IF((CLOSE = OPEN),1,0) + IF((CLOSE = J12),1,0)) + IF((CLOSE = J23),1,0)) 1);
T2:=((((CLOSE J23) AND (CLOSE J12)) AND (OPEN J23)) AND (OPEN J12));
T3:=((CLOSE = J12) AND (OPEN = J23));
T4:=(((OPEN = J12) AND (OPEN = J23)) AND (CLOSE J12));
T5:=(((OPEN = J23) AND (CLOSE = J12)) AND (CLOSE = J23));
T6:=((CLOSE = J23) AND (OPEN = J12));
T7:=(((OPEN = J12) AND (OPEN = J23)) AND (CLOSE J23));
T8:=(((OPEN = J12) AND (CLOSE = J12)) AND (CLOSE = J23));
T9:=(((SHAMOUNT / SHVOL) / 100) REF(HIGH,1));
T10:=(((SHAMOUNT / SHVOL) / 100) REF(LOW,1));
IF DISPSTATUS=2 THEN BEGIN;
GP:=' ';
IF T90 THEN GP:=GP+' 上漲趨勢。';
IF T100 THEN GP:=GP+' 下跌趨勢。';
IF T10 THEN GP:=GP+' 極端行情,在未來的幾日內有85%的機會變更方向。';
IF T20 THEN GP:=GP+' 中性行情,多空雙方都未能取得當日行情主動性的控制權';
IF T30 THEN GP:=GP+' 爬升行情,整個交易期間都有買方主導。';
IF T40 THEN GP:=GP+' 爬升行情,信息很少,但收盤期間是買方主導,其他未知。';
IF T50 THEN GP:=GP+' 爬升行情,買方把收盤價拉升到開盤價之上,賣方也在盤中主導一段行情,但不知道是誰主導最后的行情。';
IF T60 THEN GP:=GP+' 漂流行情,整個交易期間都有賣方主導。';
IF T70 THEN GP:=GP+' 漂流行情,信息很少,但收盤期間是賣方主導,其他未知。';
IF T80 THEN GP:=GP+' 漂流行情,賣方把收盤價壓至到開盤價之下,買方也在盤中主導一段行情,但不知道是誰主導最后的行情。';
IF MA20=MA60 AND CROSS(MA40,MA60) THEN GP:=GP+' 形成季托,待股價回落到20天均線或40天均線時介入,20天均價為:'+MA20+',40天均價為:'+MA40+' 。';
IF BIAS9.5 AND (C-REF(C,1))/REF(C,1)*1009.8 THEN GP:=GP+' 短線漲幅過大,有整理要求。';
IF MA20=MA60 AND H=MA20 AND L=MIN(MA40,MA60) AND CO AND CREF(C,1) THEN GP:=GP+' 芙蓉出水,趨勢向好。';
IF BIAS-18 AND (C-REF(C,1))/REF(C,1)*100-9.8 THEN GP:=GP+' 股價嚴重超跌,有爆發要求。';
IF BIAS-7 AND ALL(CLOSEOPEN,5) THEN GP:=GP+' 連收五陰,超跌有反彈要求。';
IF ABS(HIGH-REF(HIGH,1))/HIGH0.001 THEN GP:=GP+' 平頂,該高點有一定阻力。';
IF ABS(LOW-REF(LOW,1))/LOW0.001 AND ABS(REF(LOW,1)-REF(LOW,2))/REF(LOW,1)=0.00 THEN GP:=GP+' 平底,該低點有一定支撐。';
IF CLOSE=OPEN AND HIGHCLOSE AND LOWCLOSE AND HIGH/LOW 1.03 THEN GP:=GP+' 長十字,多空激爭 前途未明。';
IF OPEN/CLOSE 1.05 AND HIGH/LOW OPEN/CLOSE+0.018 THEN GP:=GP+' 大陰燭,今日空方有絕對優勢。';
IF REF(CLOSE,1)REF(OPEN,1) AND CLOSEOPEN AND CLOSE/OPEN0.98 THEN GP:=GP+' 雙飛烏鴉,多頭力竭,行情走軟。';
IF (MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)0.667 THEN GP:=GP+' 長下影,下檔支撐強或空方試探進攻。';
IF (HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)0.667 THEN GP:=GP+' 長上影,上檔阻力大或多方試探進攻。';
IF CLOSE=OPEN AND CLOSE=LOW AND CLOSEHIGH THEN GP:=GP+' 垂死十字,在頂部時重要 表強力多頭開始疲軟。';
IF HIGH=CLOSE AND HIGHLOW THEN GP:=GP+' 光頭陽線,今日尾盤多方氣盛,行情可能延續到明天。';
IF (HIGHREF(LOW,1) OR LOWREF(HIGH,1)) THEN GP:=GP+' 跳空缺口,當日未補,有與跳空同向進行,上漲欲望強烈,三日內為回補觀察期。';
IF LOW=CLOSE AND HIGHLOW THEN GP:=GP+' 赤腳陰線,尾盤空方勝。 注意股價下跌延續至次日。';
IF CLOSE=OPEN AND HIGHCLOSE AND LOWCLOSE AND HIGH CLOSE THEN GP:=GP+' 十字星,警告信號。原趨勢停頓或反轉,依上下影線長度判后市。';
IF CLOSE/OPEN1.05 AND HIGH/LOW CLOSE/OPEN+0.018 THEN GP:=GP+' 大陽燭,上升行情中意味行情劇烈向上攀升;下跌行情中意味行情劇烈向上反彈。';
IF REF(CLOSE,2)/REF(OPEN,2) 0.95 AND REF(OPEN,1) REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1)AND CLOSE/OPEN1.05 AND CLOSEREF(CLOSE,2) THEN
GP:=GP+' 早晨十字 - 如同晨星。 從看空平衡到看漲轉強;左右跳空曰棄嬰 。';
IF REF(CLOSE,4)/REF(OPEN,4)1.03 AND REF(CLOSE,3)REF(OPEN,3) AND REF(CLOSE,2)REF(OPEN,2) AND REF(CLOSE,1)REF(OPEN,1) AND REF(LOW,4)REF(LOW,3) AND REF(LOW,4)REF(LOW,2) AND REF(LOW,4)REF(LOW,1) AND REF(HIGH,4)REF(HIGH,3) AND REF(HIGH,4)REF(HIGH,2) AND REF(HIGH,4)REF(HIGH,1) AND CLOSE/OPEN1.03 AND CLOSEREF(CLOSE,4) THEN GP:=GP+' 上升三部曲,空方賣壓被吸納。 趨勢易順勢走漲。';
IF (REF(HIGH,2) -REF(O,2))/REF(HIGH,2)=0.0003 AND (C-LOW)/O=0.0003 AND REF(C,2)REF(O,2) AND REF(C,2)REF(O,1) AND REF(C,1)O AND REF(C,1)REF(O,1) AND REF(HIGH,1)-REF(O,1)0 AND REF(LOW,1)-REF(C,1)0 AND HIGH-O0 AND REF(C,2)-REF(LOW,2)0 THEN GP:=GP+' 三胎烏鴉,多頭走勢被扭轉。黑K價愈深量愈大,跳空愈大,反轉信號愈強。';
IF ((REF(CLOSE,1)REF(OPEN,1) AND CLOSEOPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE0.002) OR (REF(CLOSE,1)REF(OPEN,1) AND CLOSEOPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE0.002)) THEN
GP:=GP+' 友好反攻 - 陰(陽)線結合,極線多方跳空向下(跳空向上)后反彈有企穩跡象 。';
IF CLOSEOPEN AND MIN(OPEN,CLOSE)=LOW AND HIGH-LOW 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE MA(CLOSE,5) THEN
GP:=GP+' 射擊之星 - 如伴大量上遇阻力,有短期見頂可能,股價轉疲。';
IF REF(CLOSE,1)-REF(OPEN,1)0 AND CLOSE-OPEN0 AND OPEN-REF(CLOSE,1)0 AND CLOSEREF(OPEN,1) AND CLOSEREF(CLOSE,1) AND CLOSE(REF(CLOSE,1)+REF(OPEN,1))/2 THEN
GP:=GP+' 貫穿線,多頭力道的反撲或是空單回補力道。長陰線之后開低收在昨天1/2之上,為多頭反轉信號。';
IF ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) 0.04 AND ABS(CLOSE-OPEN)/CLOSE0.005 AND MAX(CLOSE,OPEN) MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN) MIN(REF(CLOSE,1),REF(OPEN,1)) THEN
GP:=GP+' 身懷六甲 - 陰(陽)懷陽(陰),怪異的走勢,顯示該股行情可能轉向。 若量由大轉縮,下跌趨勢更明確。';
IF (REF(C,1)-REF(O,1)0 AND C-O0 AND CREF(O,1) AND OREF(C,1)) THEN
GP:=GP+' 多頭陽線吞噬,陽包陰。反轉趨勢需量能配合量。 ';
IF ((REF(C,2)-REF(O,2)0 AND (ABS(REF(C,2)-REF(O,2)))/(ABS(REF(C,3)-REF(O,3)))2.4 AND ABS(C-O)3 AND ABS(REF(C,2)-REF(O,2))(ABS(REF(C,1)-REF(O,1))) AND REF(C,1)-REF(O,1)0 AND C-O0 AND REF(O,1) REF(C,2) AND OREF(O,1) AND CREF(C,2) AND CREF(O,2)) OR (REF(C,2)-REF(O,2)0 AND (ABS(REF(C,2)-REF(O,2)))/(ABS(REF(C,3)-REF(O,3)))2.4 AND ABS(C-O)3 AND (ABS(REF(C,2)-REF(O,2)))(ABS(REF(C,1)-REF(O,1))) AND REF(C,1)-REF(O,1)0 AND C-O0 AND REF(C,1) REF(C,2) AND CREF(C,2) AND CREF(O,2) AND OREF(C,1))) THEN
GP:=GP+' 夜星 - 從看多平衡到看空轉弱,轉空。 ';
IF ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) 0.04 AND CLOSE=OPEN AND CLOSE MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE MIN(REF(CLOSE,1),REF(OPEN,1)) THEN
GP:=GP+' 十字胎 - 似身懷六甲,轉向可能性更大,量縮觀望為宜 。';
IF REF(C,1)REF(O,1) AND C-O0 AND CREF(H,1) AND OREF(L,1) AND REF(O,1)REF(MAX(O,C),2) AND REF(C,1)REF(MIN(O,C),2) AND REF(MAX(O,C),2)REF(MAX(O,C),3) THEN
GP:=GP+' 雙人殉情 - 在上升趨勢中最后之空頭吞噬,也就是所謂的不見長紅不回頭。 ';
IF (REF(C,1)-REF(O,1)0 AND C-O0 AND CREF(O,1) AND OREF(C,1)) THEN
GP:=GP+' 陰線吞噬,陰包陽,向空反轉。 ';
IF REF(CLOSE,1)/REF(OPEN,1)0.97 AND CLOSE/OPEN1.03 AND OPENREF(CLOSE,1) AND CLOSEREF(CLOSE,1) THEN GP:=GP+' 曙光,與烏云蓋頂相反,行情將演化為V型反轉或止跌橫盤趨勢 。';
IF (REF(C,1)-REF(O,1)0 AND C-O0 AND CREF(O,1) AND OREF(C,1)) THEN
GP:=GP+' 多頭孕育線,陰育陽。多頭反轉可能。';
IF (REF(C,1)-REF(O,1)0 AND (ABS(REF(C,1)-REF(O,1)))/(ABS(REF(C,2)-REF(O,2)))2.4 AND C-O0 AND CREF(O,1) AND REF(C,1)-O2) THEN
GP:=GP+' 空頭孕育線,陽育陰。看空 。';
IF (REF(C,1)-REF(O,1)0 AND C-O0 AND CREF(C,1) AND OREF(O,1) AND O-C 6) THEN
GP:=GP+' 空頭孕育線,陰育陰。看空。';
IF REF(CLOSE,2)REF(OPEN,2) AND REF(CLOSE,1)REF(OPEN,1) AND CLOSEOPEN AND REF(CLOSE,1)REF(CLOSE,2) AND CLOSEREF(CLOSE,1) THEN
GP:=GP+' 三只烏鴉 - 強烈轉空趨勢,陰線越深量越大越易下跌。';
IF REF(CLOSE,4)/REF(OPEN,4)0.97 AND REF(CLOSE,3)REF(OPEN,3) AND REF(CLOSE,2)REF(OPEN,2) AND REF(CLOSE,1)REF(OPEN,1) AND REF(LOW,4)REF(LOW,3) AND REF(LOW,4)REF(LOW,2) AND REF(LOW,4)REF(LOW,1) AND REF(HIGH,4)REF(HIGH,3) AND REF(HIGH,4)REF(HIGH,2) AND REF(HIGH,4)REF(HIGH,1) AND CLOSE/OPEN0.97 AND CLOSEREF(CLOSE,4) THEN
GP:=GP+' 下跌三部曲,多方弱勢不堪一擊,趨勢易順勢走跌。';
IF REF(CLOSE,4)/REF(OPEN,4)1.02 AND REF(CLOSE,3)REF(OPEN,3) AND REF(CLOSE,2)REF(OPEN,2) AND REF(CLOSE,1)REF(OPEN,1) AND REF(CLOSE,4)=REF(CLOSE,3) AND REF(HIGH,2)REF(HIGH,3) AND REF(LOW,2)=REF(OPEN,4) AND REF(HIGH,1)REF(CLOSE,4) AND REF(LOW,1)REF(OPEN,4) AND CLOSE/OPEN1.01 AND OPEN=REF(OPEN,1) AND CLOSE=REF(HIGH,3) THEN
GP:=GP+' 連續型態之執墊,比上升三法更具多頭意義。';
IF REF(O,1)/REF(C,1) 1.05 AND REF(H,1)/REF(L,1) REF(O,1)/REF(C,1)+0.018 AND CO AND OREF(L,1) AND C=REF(L,1) THEN
GP:=GP+' 頸上線 - 下降趨勢。若第二天大量,維持原趨勢的可能性大增。';
IF (REF(C,1)-REF(O,1)0 AND (ABS(REF(C,1)-REF(O,1)))/(ABS(REF(C,2)-REF(O,2)))2.5 AND C-O0 AND CREF(O,1) AND C(REF(CLOSE,1)+REF(OPEN,1))/2 AND OREF(C,1)) THEN
GP:=GP+' 烏云罩頂 - 上漲遇重大阻力。空頭聚力。';
IF (REF(C,1)-REF(O,1)0 AND C-O0 AND CREF(O,1) AND OREF(C,1)) THEN
GP:=GP+' 最后吞噬 - 在下降趨勢中為一陰一陽組合,多頭吞噬;在上升趨勢中為一陽一陰組合,空頭吞噬。';
IF REF(OPEN,1)REF(CLOSE,1) AND REF(CLOSE,2)/REF(OPEN,2) 0.95 AND REF(OPEN,1) REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)0.03 AND CLOSE/OPEN1.05 AND CLOSEREF(CLOSE,2) THEN
GP:=GP+' 晨星 - 多方勢盛 變盤信號';
IF MIN(OPEN,CLOSE)=LOW AND HIGH-LOW 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE MA(CLOSE,5) THEN GP:=GP+' 倒轉槌頭 - 高位拋壓或低位多空爭執';
IF HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE MA(CLOSE,5) THEN GP:=GP+' 槌頭 - 下影線有多頭意義。在下降趨勢之后看漲。注意反彈賣壓 。';
IF HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE MA(CLOSE,5) THEN GP:=GP+' 吊頸線 - 高檔看跌。';
IF ((REF(CLOSE,1)/REF(OPEN,1)1.03 AND CLOSE/OPEN0.96 AND CLOSEREF(OPEN,1) AND OPENREF(CLOSE,1)) OR (REF(CLOSE,1)/REF(OPEN,1)0.97 AND CLOSE/OPEN1.04 AND CLOSEREF(OPEN,1) AND OPENREF(CLOSE,1))) THEN
GP:=GP+' 穿頭破腳 - 若第一根K為陰(陽) 表強勁上漲(下跌)力量。';
IF REF(OPEN,1)REF(CLOSE,1) AND REF(CLOSE,2)/REF(OPEN,2) 1.03 AND REF(OPEN,1) REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)0.02 AND CLOSE/OPEN0.97 AND CLOSEREF(CLOSE,2) THEN
GP:=GP+' 黃昏之星 - 空方勢盛。反轉信號,跳空成棄嬰。';
IF REF(CLOSE,2)REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)=2/100 AND REF(OPEN,1)=REF(CLOSE,1) AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)=2/100 AND REF(OPEN,1)=REF(CLOSE,2) AND REF(CLOSE,1)=REF(OPEN,2) AND C=OPEN AND (CLOSE-OPEN)/OPEN=2/100 AND CLOSE=REF(OPEN,1) AND OPEN=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))=1/100 THEN GP:=GP+' 二陽夾一陰,必須從后續的走勢來研判。';
IF OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))0 THEN
GP:=GP+' 分離 - 兩日開盤相同 一陰一陽 變盤前徹底整理。';
IF ((OC AND OPENMA(C,5) AND OPENMA(C,10) AND OMA(C,20) AND CLOSEMA(C,5) AND CLOSEMA(C,10) AND CLOSEMA(C,20)) OR (OC AND OPENMA(C,5) AND OPENMA(C,10) AND OMA(C,20) AND CLOSEMA(C,5) AND CLOSEMA(C,10) AND CLOSEMA(C,20))) THEN GP:=GP+' 斷頭鍘刀(出水芙蓉) -一根大陰(陽)線切斷了三根均線 如果改變了其后均線的排列為空頭(多頭)排列 后勢看空(多) 。';
END;
{MY指標公式網http://www.pdopuy.live/}
TIPTEXT(DISPSTATUS=2,0,GP);
LC:=REF(CLOSE,1);
rsi1:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;
SELL1:=FILTER((CROSS(RSI1,88)),7);
SELL2:=(CROSS(88,RSI1));
kdj:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(KDJ,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
TYP:= (HIGH + LOW + CLOSE)/3;
cci:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DRAWTEXT(SELL1,HIGH*1.02,'預警'),COLORCC33CC,ALIGN2,VALIGN2;
DRAWTEXT(SELL2,HIGH*1.02,'▼'),COLORFFCC33,ALIGN1;
DRAWTEXT(SELL2 AND (K80 OR CCI160),HIGH*1.04,'▼'),COLORCC6633,ALIGN1;
DRAWTEXT(SELL2 AND K80 AND CCI160,HIGH*1.06,'▼'),COLORFF3300,ALIGN1;
VB1:=AMOUNT/V;
VB2:=LVB1*0.9;
VB3:=(C-REF(C,1))/REF(C,1)*1001.2;
VB4:=LMA(C,5)*0.921;
VB5:=VMA(V,5)*1.5;
VB6:=VB2 AND VB3 AND VB4 AND VB5;
VB7:=EMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,34)-LLV(LOW,27))*4,4)*25;
VB8:=IF((VB710),80,100);
VB9:=IF(K20,10,0);
VB10:=LLV(J,2)=LLV(J,8);
VB11:=IF(CROSS(J,REF(J+0.01,1)) AND VB10 AND J20,30,0);
DRAWTEXT(VB11 AND VB8=100 AND VB9=10,LOW*0.99,'超跌'),COLOR8000FF;
VB12:=C-REF(C,1);
VB13:=100*EMA(EMA(VB12,6),6)/EMA(EMA(ABS(VB12),6),6);
VB14:=IF(LLV(VB13,2)=LLV(VB13,7) AND COUNT(VB130,2) AND CROSS(VB13,MA(VB13,2)),1,0);
VB15:=FILTER((VB14=1 OR VB6),7);
VB16:=FILTER(VB6,5);
VB17:=FILTER(VB14=1,5);
DRAWTEXT(VB17,LOW*0.97,'短線'),COLOR66CCFF;
DRAWTEXT(VB16,LOW*0.98,'考慮介入'),COLOR336699,ALIGN2;
止損:=(LC*1.0035*97+0.2)/99.65;
DRAWTEXTABS(5,9,'止損價位: '+NUMTOSTRN(止損,2)+' 元'),COLORWHITE;
VC:=(HIGH+LOW+OPEN+2*CLOSE)/5;
明日阻力:=2*VC-LOW;
明日支撐:=2*VC-HIGH;
明日突破:=VC+(HIGH-LOW);
明日反轉:=VC-(HIGH-LOW);
今日阻力:=REF(明日阻力 , 1);
今日支撐:=REF(明日支撐 , 1);
DRAWTEXTABS(5,25,'今日阻力: '+NUMTOSTRN(今日阻力,2)+' 元'),COLOR00FF00;
DRAWTEXTABS(5,41,'今日支撐: '+NUMTOSTRN(今日支撐,2)+' 元'),COLORRED;
DRAWTEXTABS(5,57,'明日突破: '+NUMTOSTRN(明日突破,2)+' 元'),COLORYELLOW;
DRAWTEXTABS(5,73,'明日阻力: '+NUMTOSTRN(明日阻力,2)+' 元'),COLOR00FF00;
DRAWTEXTABS(5,89,'明日支撐: '+NUMTOSTRN(明日支撐,2)+' 元'),COLORRED;
DRAWTEXTABS(5,105,'明日反轉: '+NUMTOSTRN(明日反轉,2)+' 元'),COLORFFFF00;
HHVALL(HIGH)*1.1,COLOR000000;
LLVALL(LOW)*0.9,COLOR000000;
版權聲明

本文僅代表作者觀點,不代表MY指標公式網立場。
本文系作者授權MY指標公式網發表,未經許可,不得轉載。

文章內容來自互聯網,本網站無任何收費項目也不推薦股票
廣告投放請自行識別風險。本站無任何QQ群微信群

分享:

掃一掃在手機閱讀、分享本文

p3试机号开奖助手